Image Layers

To create a new image layer you can follow these simple steps:

  1. If you want to convert any picture file into a layer, right click on the layers list and choose Create new layer from file.. ;

  2. if you want to create a layer from the current selection just choose from main menu Edit > copy and then choose Edit > Paste as new layer.

  3. You can also create a blank layer: right click the layers list and choose Create new blank layer.

  4. Remember also that you can create a layer from the current Object just promoting it to a layer (Object > Promote to layer).

  5. When a new layer is created the layers window is opened automatically.

  6. You can control all about the newly created layer: position, name, percent amount of blending, blending mode.

 

Commands of Layer Window:

Layers List: lists the existing image Layers. Those checked are the ones currently visible. To hide a layer, just uncheck the corresponding item in the list.

The background is a special layer and thus is always visible.

The first layer from the top is the background. All other layers lay on top of that.

Z-Order Arrows:

Use the arrows to bring a layer on top of another or back down.

Merge Button:

This command merges the selected layer with the background. After this, the layer is not deleted but just made invisible.

Delete Button:

Command to delete a layer.

Warning this operation cannot be undone, so be careful before deleting any layer.

Layer Display:

Shows the 4 channels of which the layer is made. The 3 color channels make the picture on the left, the alpha channel is the see-through region of the layer.

Blend Mode:

the Blend Mode is the way the layer is combined with the background and the underlaying layers. There are many blend modes, by default it is set to Normal.

 

You can also control:

  • Percent of blending (opacity)

  • Layer Position (X, Y)

  • Layer Width and Height

The Alpha Channel

An image layer is made of 4 channels: 3 RGB channels represent the color information, and the alpha channel is an extra information which represents the opacity of the layer: the more is the alpha value of a single pixel the more that pixel will be visible. Pixels with an alpha value of 0 will not be visible, pixels with 127 will be just half-visible and pixels with 255, maximum value, will be completely visible.

You can edit the alpha channel separately using the alpha channel editor.

To cut away parts of the alpha channels you can use the Edit > Cut Command together with a selection.

You can also modify the transparence of alpha channel using the "Erase/Restore layer  tool".

Also if in the Layer Window the Edit Alpha Channel option is checked you will be able to edit the alpha channel with most of the editing tools. If the option is not checked the alpha channel will not be affected during editing.

These are also many operations you can do with Image Layers like:

From this window you can:

- "Flatten Group" operation has the effect of joining all the layers of the group into one big layer. The old layers will not be deleted but just set to invisible in case you want to restore them later.

- You can also apply group alignment operations to set the position of all layers in the group